[Lablgtk-list] How-to make packages for 2.16

Adrien camaradetux at gmail.com
Tue Aug 28 08:43:30 CEST 2012

On 28/08/2012, Adrien <camaradetux at gmail.com> wrote:
> For instance, the META in godi used to always pull GtkInit. In turn,
> that tried to init, well, GTK+. That required running under X. Having
> to start an X server simply to build lablgtk2 was a bit annoying.

That was when building ocamlnet-gtk2: the configure script in this
package builds and run a trivial program which links against lablgtk2
in order to check some API works. Having auto-init there prevented the
configure script from running from outside of X.

Adrien Nader

More information about the Lablgtk-list mailing list